【注意】Unity2021.1将不兼容之前版本ECS

时间:2021-7-3 作者:qvyue

本文首发公众号洪流学堂。洪流学堂,让你快人几步。

Unity 2021.1以后,DOTS会有较大更新。

DOTS生态中的部分包 (Burst, Jobs, Math, Collections) 继续兼容Unity 2021.1技术版(但是没说会继续兼容之后的版本),但其他包比如Entities(以及依赖Entities的包)不再兼容

DOTS中的Burst以及相关的包是可在生产环境中用的,但是目前Entities相关的包仍然处于试验版,且正式版何使发布仍未知。如此看来,基于DOTS的小游戏包Tiny也会遥遥无期,想开发微信小游戏的童鞋先不用指望了,还是换到友商吧。

如果你的项目使用了DOTS想升级到Unity2021,有两种情况:

情况A – 项目没用entities包

你可以将项目升级到2021并继续用Burst以及相关的包。

情况B – 项目用了entities包

暂时不能升级到2021,你得保持在Unity 2020 LTS以及Entities 0.17。未来大约一年发布的Entities版本将不兼容旧版本。升级到2021.1后,entities无法正常使用。

关于DOTS更新的最新进展可以关注原文链接:
https://forum.unity.com/threads/notice-on-dots-compatibility-with-unity-2021-1.1091800/

声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至:qvyue@qq.com 进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。